PLE forum

Full Version: Autofit columns not working for the row number column
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Affected version: Ple4Win v4.2.0
Reproducible: Always.

Pasting data from Excel to Ple4Win or add extra rows in an input table leads to a string length which is greater then the column width. The row column isn't automatically fitted, so a part of the number is missing.

This happens with the row number column, see printscreen below.


The setting in the Ple4Win options is as follows:


This happens also with the text in the other columns. If the text in the cells is greater then the column width the column isn't autofitted.
The effect you describe is known to us. Currently, the columns widths are calculated when opening the table. There is no recalculation of any column width while the table is shown.
We probably will not implement any "dynamic autosize" in the near future. One reason is that calculating the widths is rather complex, especially with larger tables. However, we might increase the default width for e.g. ID-columns or text columns.
We assigned ticket no. 1115 to this issue.
Yes, the default width can be increased so that at least 3 figures can be displayed in the column.

P Herwig MSc

The default width of the ID column is set to three digits in the upcoming release.