PLE forum

Full Version: Major bug: auto toggling doesn't work in Ple4Win v4.6.1
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Affected version: Ple4Win Professional 4.6.1


The auto toggling function from Identifier to AX-L doesn't work in the new Ple4Win version when importing from Excel.
I have attached the Excel import file.

Can this version be patched as soon as possible?

Could you please elaborate? I imported your Excel-file into a new, empty project file without any problems (using multi-table import).
As far as I can see only the DEADW and SUBSIDE tables use AX-L based data, and both tables are toggles correctly after import from Excel.
Yes, I have AX-L in the DEADW and SUBSIDE.




This issue doesn't occurs in version v4.6.0, but only in v4.6.1.

I am using Windows 10 Pro v1909 with the 11 February 2020 patch.
I have tested it on two machines and got the same error.

This happens also with other Excel import files.
We have to look into this. So far, this behaviour is not reproducible here. I'll keep you informed.
Maybe it has to do with regional settings. My current regional setting in the OS is NL-NL (Dutch). Or maybe it has to do with points and commas.
I think, the behaviour before the moment of auto-toggling should be checked in the source and especially the source change between version 4.6.0 and 4.6.1.

According to the changelogs, these changes are made regarding to importing Excel files:
• Single table Excel import now does select appropriate sheet (if available)
• Speed improvements with import of (large) Excel tables
• Importing (single) table toggles the table according to the Excel contents, even if a double-toggle-column table

I think, maybe the speed improvements are rejecting the auto-toggling. Maybe the speed improvement before auto-toggling should be decreased and afterwards increased.
All the ideas you mentioned are considered by us. None of those should influence the auto-toggling (column headers are evaluated, not the data itself), but apparently something does happen. We are still  searching...
I'm still not able to reproduce this issue, still I assigned ticket no J-2370 to this problem.

I am working on some improvements that might help but without a way of testing these I can not guarantee that these will improve the program's behaviour in your case.
I will checked it again.

I installed also the latest Cumulative Update (CU) of yesterday for Windows 10 v1909 build CU is 18363.693 (KB article: KB4535996).
The issue still exists here and can be reproduced.

Rewriting the code might help.

There is another issue when importing a Excel file (see attached file, which is created by Ple4Win 4.6.1) into Ple4Win v4.6.0.

Some tables are not fully imported with the import module, see screenshot below:


Is this last addition somehow connected to this thread?

Again the problem is that it is not (yet) reproducible here. I tried importing your file through multiple ways (full mult-table import, selected tabels only in multi-table import, single table import), but the import is always complete, there is no (column) data missing.

We will look into this further, but this is some fleeting bug Sad
Pages: 1 2