This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Major bug: auto toggling doesn't work in Ple4Win v4.6.1
15-02-2020, 12:11 PM, (This post was last modified: 16-02-2020, 07:20 PM by shaswin.)
#1
Major bug: auto toggling doesn't work in Ple4Win v4.6.1
Affected version: Ple4Win Professional 4.6.1

Hello,

The auto toggling function from Identifier to AX-L doesn't work in the new Ple4Win version when importing from Excel.
I have attached the Excel import file.

Can this version be patched as soon as possible?

Thanks.


Attached Files
.xlsx   Excel import.xlsx (Size: 51,89 KB / Downloads: 4)
Reply
17-02-2020, 09:45 AM,
#2
RE: Major bug: auto toggling doesn't work in Ple4Win v4.6.1
Could you please elaborate? I imported your Excel-file into a new, empty project file without any problems (using multi-table import).
As far as I can see only the DEADW and SUBSIDE tables use AX-L based data, and both tables are toggles correctly after import from Excel.
Reply
17-02-2020, 12:19 PM, (This post was last modified: 17-02-2020, 12:21 PM by shaswin.)
#3
RE: Major bug: auto toggling doesn't work in Ple4Win v4.6.1
Yes, I have AX-L in the DEADW and SUBSIDE.

   

   

   

This issue doesn't occurs in version v4.6.0, but only in v4.6.1.

I am using Windows 10 Pro v1909 with the 11 February 2020 patch.
I have tested it on two machines and got the same error.

This happens also with other Excel import files.
Reply
17-02-2020, 03:21 PM,
#4
RE: Major bug: auto toggling doesn't work in Ple4Win v4.6.1
We have to look into this. So far, this behaviour is not reproducible here. I'll keep you informed.
Reply
18-02-2020, 07:29 AM, (This post was last modified: 18-02-2020, 10:06 AM by shaswin.)
#5
RE: Major bug: auto toggling doesn't work in Ple4Win v4.6.1
Maybe it has to do with regional settings. My current regional setting in the OS is NL-NL (Dutch). Or maybe it has to do with points and commas.
I think, the behaviour before the moment of auto-toggling should be checked in the source and especially the source change between version 4.6.0 and 4.6.1.

According to the changelogs, these changes are made regarding to importing Excel files:
• Single table Excel import now does select appropriate sheet (if available)
• Speed improvements with import of (large) Excel tables
• Importing (single) table toggles the table according to the Excel contents, even if a double-toggle-column table

I think, maybe the speed improvements are rejecting the auto-toggling. Maybe the speed improvement before auto-toggling should be decreased and afterwards increased.
Reply
18-02-2020, 10:27 AM,
#6
RE: Major bug: auto toggling doesn't work in Ple4Win v4.6.1
All the ideas you mentioned are considered by us. None of those should influence the auto-toggling (column headers are evaluated, not the data itself), but apparently something does happen. We are still  searching...
Reply
28-02-2020, 04:11 PM,
#7
RE: Major bug: auto toggling doesn't work in Ple4Win v4.6.1
I'm still not able to reproduce this issue, still I assigned ticket no J-2370 to this problem.

I am working on some improvements that might help but without a way of testing these I can not guarantee that these will improve the program's behaviour in your case.
Reply
28-02-2020, 06:15 PM,
#8
RE: Major bug: auto toggling doesn't work in Ple4Win v4.6.1
I will checked it again.

I installed also the latest Cumulative Update (CU) of yesterday for Windows 10 v1909 build CU is 18363.693 (KB article: KB4535996).
The issue still exists here and can be reproduced.

Rewriting the code might help.
Reply
06-03-2020, 01:20 PM,
#9
RE: Major bug: auto toggling doesn't work in Ple4Win v4.6.1
Hello,

There is another issue when importing a Excel file (see attached file, which is created by Ple4Win 4.6.1) into Ple4Win v4.6.0.

Some tables are not fully imported with the import module, see screenshot below:

   

   


Attached Files
.xlsx   BC3 ambiënt.xlsx (Size: 43,9 KB / Downloads: 2)
Reply
06-03-2020, 03:37 PM,
#10
RE: Major bug: auto toggling doesn't work in Ple4Win v4.6.1
Is this last addition somehow connected to this thread?

Again the problem is that it is not (yet) reproducible here. I tried importing your file through multiple ways (full mult-table import, selected tabels only in multi-table import, single table import), but the import is always complete, there is no (column) data missing.

We will look into this further, but this is some fleeting bug Sad
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)